Card Authorisation Failed - Debit Card

I tried to pay PSEG bill payment using Envel debit card. Though I have sufficient amount in Bill Envelope, the payment was declined. I got an error message on PSEG website " Card Authorisation Failed". Kind of disappointing.

1 Like

I manually moved the funds from Bill to Cash envelope. Then the payment went through. But I faced two issues.

  1. I still don’t see this expense in Cash Trasactions page
  2. The notifications (received two) were not clear. It didn’t alert me that the bill was paid. Instead, it said “Tried to Spend $147 at cash? Sorry no more Cash Available today” :thinking: :thinking:
1 Like

Thanks @Nomad, I’m currently discussing the issues with the developers. Will come back to you shortly!

1 Like

So far this app is pretty frustrating, I’m not gonna go on a page length of rant so… , 1) it took almost 2 weeks for me to get access to my first paycheck when switching Simple, 2) it doesn’t allow me to transfer to any of my Virtual envelopes, and when I follow the directions to transfer from the spend envelope I choose “bank “ and it has one in there already, and there is no way, that I can see to delete it or add another one.

I’ve tried contacting support for this and no answer. There is also no information on how to unlink an account. And finally 3) I just received a charge from some third party company of my apartments, for $25 because when I transferred $700 to my apartment to pay rent, 2 days later it kicked it back to me saying “insufficient funds” um what? So I’m being charged for “NOT HAVING MONEY” when I clearly do… so can someone please help me unlink an external account, not a virtual envelope account so I can transfer my money elsewhere and get rid of this headache please thanks :weary:

Hello James @Jfred ,

Thank you for your message and apologies for the inconvenience. To come back to your questions.

  1. There was intermittent issue with some direct deposits being stuck in the income splitter. Data from our core banking service was not sent in the right way and therefore transactions remained pending while in reality they were already settled. We discussed this on the support chat 6 days ago and this was fixed.

  2. A) We are bound by our banking partner to allow only one external funding source for their ACH scheme. Also our banking partner puts a 3 day hold on incoming ACHs. We realized quickly that this was far from ideal for the user as no-one should wait for their money these days.
    B) We’re working with Plaid to solve this. While at this point Virtual Envelopes are basically “just for show”, we’re currently in internal testing for same day and next day ACHs between Virtual Envelopes. Allowing the user to link multiple external funding sources with easy transfers.
    C) Please read the step by step guide below on how to remove a linked account. Two lessons for us; 1) start pumping out more FAQ articles but more importantly 2) make things more intuitive in the app and improve our UI.

  3. We’re very sorry about the charge, we’ll contact you about a reimbursement since there was insufficient funds in your cash Envelope due to the issue described in point 1.

The step by step guide

  • Go to your Wallet screen
  • Click on Add Funds
  • Select Pull
  • Swipe your external account
  • Click on the trashcan icon

Again apologies for the inconvenience we have caused.

1 Like